Extended Maintenance

Incident Report for OSL Digital Securities

Resolved

This incident has been resolved.
Posted Jul 13, 2025 - 08:38 HKT

Investigating

OSL Digital Securities Exchange ATS (Automate Trading Service) is currently undergoing an extended maintenance period. We are working to resume the service as quickly as possible - apologies for any inconvenience caused.

Other services are not affected.
Posted Jul 13, 2025 - 08:08 HKT
This incident affected: OSL Exchange (User Interface, REST API, FIX API).